Sommario

www.pcopen.it
Per accedere agli argomenti interessati, cliccare sulle voci sottolineate.
Condizioni d'uso
Requisiti di sistema
L'interfaccia del cd rom
Il backup (copia di sicurezza)
Consigli per l'installazione
Che cosa fare in caso di problemi
Assistenza tecnica
Adware e Spyware
Shareware e Freeware
I Virus
Come creare le icone dei programmi
Chi siamo
============================================================
File di guida in formato ipertestuale - Compatibile Windows 9x, Me, 2000, XP
A cura di Luigi Callegari (luigicallegari@hotmail.com)
============================================================


Adware e Spyware

Recentemente, con l'enorme diffusione di Internet, si è creata una nuova tipologia di sponsorizzazione dei programmi di pubblico dominio, con alcune problematiche delicate e complesse connesse.
Molti autori e software house incorporano attualmente nei propri software una tecnologia chiamata "adware". Si tratta di un sistema, realizzato da alcune software house (Aureate, Radiate, Time Sink ecc.) che consente all'autore del programma che lo adotta di ricevere denaro quando gli utenti usano il software. Questo rimane di solito del tutto gratuito, ma visualizza dei banner pubblicitari (in effetti, immagini in formato Gif animate) in modo automatico, che vengono prelevate in modo autonomo dal software quando siamo collegati ad Internet.
Per ogni visualizzazzazione (jn gergo, "impression") di un banner pubblicitario nel programma adware l'autore riceve una piccola somma in denaro dal produttore della tecnologia che ha incorporato. Il denaro arriva da società di ogni tipo (a livello nazionale, europeo o mondiale) che pagano i produttori delle tecnologie adware per distribuire i banner animati attraverso i programmi installati. I banner sono fisicamente inseriti nei server Internet di tali società e inviati ai software prodotti dagli autori di adware in modo automatico, quando si collegano. In questo modo, esistono statistiche precise circa il numero di copie installate e funzionanti di un certo programma adware nel mondo e il numero e tipo di banner visualizzati dagli utenti.
Come funziona la tecnologia adware
Un autore o software house può facilmente inserire il codice adware, che richiede a uno dei produttori. Viene stipulato un accordo tale per cui l'autore inserisce la tecnologia e il produttore della tecnologia remunera un compenso all'autore in base al numero di "impression" pubblicitarie che attraverso il suo programma verranno mandati agli utenti nel mondo. Quando un programma incorpora la tecnologia adware, non deve mutare alcuna delle sue funzioni, infatti esistono software adware di ogni tipo. Solo che una piccola parte dell'interfaccia del programma deve essere riservata ai banner animati.
Quando l'utente installa un software adware, a volte deve anche compilare un piccolo questionario (contenente domande del tipo: attività, reddito annuo, interessi ecc.) , che di regola però non è obbligatorio a che il programma funzioni. Tali dati vengono inviati in modo automatico, via Internet, al server del produttore di adware che può quindi decidere in modo più mirato quali tipi di banner pubblicitari inviare a quella specifica copia installata. La pubblicità risulta dunque più efficace e può essere fatta pagare di più alle società inserzioniste.
La gran parte delle tecnologie adware funziona anche se non si è connessi ad Internet. Infatti, alcuni banner predefiniti vengono installati con il programma in una cartella riservata e visualizzati anche se non si dispone di connessione Internet. Allo stesso modo, quando ci si collega vengono prelevati altri banner e memorizzati in tale cartella, per potere essere visualizzati in seguito anche se la connessione ad Internet viene terminata.
I vantaggi
La gran parte dei programmi di pubblico dominio è sempre stata di tipo shareware. L'autore ne consentiva cioè l'uso a tempo determinato (30-60 giorni) dopo di che il programma cessava di funzionare se non si acquistava la versione completa od un codice di attivazione. In altri casi, le versioni shareware non hanno limitazioni di tempo di funzionamento, ma altre limitazioni. Ad esempio, non stampano, "sporcano" le stampe con scritte predefinite non eliminabili, non salvano i file, presentano pannelli di ritardo all'avviamento ed all'uscita del software ed altro. Tutto per incentivare l'utente che ha provato il programma gratuitamente a registrarsi, a pagamento, per eliminare questi problemi.
Tuttavia, è un dato di fatto che questo sistema non è particolarmente remunerativo. Molti utenti non sono inclini a pagare via Internet o con carta di credito ( o addirittura con contanti o bonifici bancari internazionali) società piccole, o addirittura singoli privati, spesso lontane geograficamente e sconosciute rischiando magari di non ricevere alcun codice di attivazione o il software completo. Altri non pensano di pagare per usare un programma che non li soddisfa appieno. In tutti i casi, gli autori di shareware ricevono spesso poco denaro da questo sistema.
L'adware cambia totalmente il sistema introducendo una remunerazione automatica, certa e sicura degli autori in base all'effettivo uso del loro programma. Ogni copia installata è "conosciuta" dai server della società adware che raccoglie pubblicità e la invia tramite Internet. Gli autori ricevono da tale società una piccolissima cifra di denaro per ogni "impression". Anche se sono poche lire, qualora un programma sia valido e quindi diffuso in migliaia o milioni di copie (come è il caso di certi adware di successo, ad esempio Go!Zilla, Flash Get, Copernic 2000 e molti altri), può rendere ricco il suo autore.
Dal punto di vista degli utenti è indubbiamente un vantaggio avere un programma che funziona senza limitazioni, è di fatto gratuito ed in cambio richiede solo di visualizzare semplici Gif animate pubblicitarie. Tra l'altro, quando si clicca su una di queste gif animate si può visitare subito il sito del produttore, offrendo così un sistema informativo di nuovi prodotti e servizi che, per alcuni, può effettivamente essere utile (come dovrebbe essere uno degli scopi di ogni pubblicità). E' lo stesso meccanismo usato dai media come stampa, radio e televisioni: spettacoli, informazioni e servizi in cambio di spot pubblicitari.
L'utente non deve versare obbligatoriamente denaro per avere un programma completo e funzionante. In effetti, in alcuni casi, i produttori offrono la possibilità di registrarsi ai programmi adware. Pagando una somma in denaro, di solito attraverso carta di credito su server Internet sicuri, si può eliminare la tecnologia adware dal programma e, a volte, ottenere funzionalità aggiuntive evolute.
Problemi della tecnologia adware
Come descritto, il meccanismo adware comporta un rallentamento molto lieve della velocità di connessione ad Internet. Infatti, se si usa un software adware, ogni tanto questo richiederà alla rete di ricevere un nuovo banner. Il trasferimento sottrae dunque una piccola parte della velocità possibile di dialogo tra il nostro personal computer ed Internet (la cosiddetta "banda di trasferimento"). Diciamo che la cosa è talmente ridotta, di regola, da essere di fatto difficile da ravvisare e persino invisibile durante l'uso di Internet se si usano linee digitali (Isdn, Adsl ecc.). L'aggiornamento dei banner pubblicitari infatti richiede pochissimi secondi e viene eseguito ad intervalli di tempo piuttosto lunghi.
Un problema ben più delicato è determinare quale tipo di informazione venga effettivamente scambiata tra il programma adware e il server della società produttrice e come vengano utilizzati i dati raccolti sull'utente. Tutte le società produttrici di tecnologia adware "serie" hanno un'ampia documentazione sul loro sito che spiega quale tipo di informazioni vengono raccolte sugli utenti (a volte solo se hanno installato il programma, altre volte come lo usano, che siti Internet visitano attraverso di esso, quanto tempo si collegano ad Internet ed altro ancora) e come vengono utilizzate. In pratica, è simile a quanto in Italia è imposto dalla Legge 675/96 sulla tutela della Privacy. legge che però non è internazionale, perciò può non essere, ad esempio, possibile richiedere la rimozione dei propri dati dall'archivio dei produttori adware.
Spyware
A questo proposito è nato il termine "spyware". E' teoricamente possibile in modo piuttosto facile introdurre meccanismi nei software, di ogni tipo (anche commerciali) che dialoghino con server Internet in modo a noi del tutto trasparente, inviando dati anche riservati. Alcune delle tecnologie adware sono state esaminate proprio per ricercare se questo fosse effettivamente fatto, ovvero se i software effettivamente inviassero dati riservati e diversi da quanto specificato espressamente dal produttore. La risposta, per tutte le società note, è stata negativa: i software adware di quasi tutti i produttori inviano esclusivamente informazioni "innocue" e citate nella documentazione del produttore adware su Internet.
Gli spyware però esistono in teoria: sarebbero equiparabili a dei virus che, sebbene non possano replicarsi in modo autonomo a livello di programma, possono agire a nostra insaputa, raccogliendo dati riservati (la password di connessione ad Internet, i numeri seriali dei programmi installati, ed altro) ed inviarli a server remoti. Il virus Melissa, ad esempio, svolgeva proprio anche questa funzione. I dati riservati, essendo memorizzati comunque sui nostri dischi (nei file o nel Registry di Windows) sono infatti facilmente reperibili da un programma e altrettanto semplicemente inviabili via Internet in modo del tutto trasparente.
In effetti, qualunque software anche commerciale potrebbe in teoria inviare informazioni a nostra insaputa. Chi garantisce che quando stiamo scrivendo con una qualunque videoscrittura, od un foglio di calcolo, una copia del documento non venga inviato via Internet a qualche server remoto? In teoria nulla: non ce ne accorgeremmo nemmeno, dato che durante l'invio noteremmo soltanto un minuscolo rallentamento della navigazione ad Internet (se la stiamo eseguendo), imputabile a tanti fattori (disturbi sulla linea telefonica, intasamento dei server dei siti che visitiamo, problemi sulla rete ecc. ecc.).
In realtà, nessun programma commerciale usa questi sistemi per un semplice motivo. Essendo diffusi e quindi in mano anche a persone esperte che sanno analizzare che cosa avviene sulla connessione Internet, se avvenissero questi dialoghi la cosa sarebbe nota. In molti paesi del mondo queste società produttrici sarebbero trascinate in Tribunale per violazione delle leggi sulla privacy e spionaggio. Basti pensare che gli stessi programmi commerciali che usiamo noi sono spesso usati anche da enti governativi e militari.
La sicurezza di Pc Open
Per una precisa scelta editoriale, sul nostro cd rom usiamo diffondere preferibilmente software non solo utili ed interessanti, documentati in italiano, ma anche gratuiti. Questo comporta che una percentuale significativa dei programmi presentati sul nostro cd rom utilizzi tecnologia adware.
Noi di Pc Open siamo stati tra i primi, sin dal novembre 2000, a parlare in Italia in modo chiaro delle problematiche adware, argomento sul quale esiste tuttora una diffusa ignoranza anche a livello dei media, comprese molte riviste di informatica italiane e siti Internet.
Tuttora infatti esistono riviste con cd rom e siti Internet che equiparano freeware, shareware e adware senza avvisare gli utenti che installando certi programmi in effetti stanno inserendo della tecnologia adware nel proprio computer. In alcuni casi, vengono diffusi programmi dotati di tecnologie adware sconosciute, possibilmente spyware o di produttori che non offrono sufficienti garanzie di tutela della privacy.
La nostra politica editoriale è totalmente diversa. Ogni programma offerto sul cd rom viene testato anche per esaminare se usa tecnologia adware e di quale produttore sia. Se essa non è nota, o se il produttore non informa sul proprio sito del tipo di trattamento delle informazioni raccolte attraverso il software, noi non inseriamo questo programma sul cd rom, per quanto esso possa essere interessante o utile.
Inoltre, nella documentazione da noi redatta in italiano per ogni programma (quella che appare cliccando sul pulsante "Documentazione") viene sempre precisato quando un programma utilizza tecnologia adware. Un servizio che, come rivista, siamo tra i pochissimi, forse i soli, ad offrire in Italia ai nostri lettori; e anche rispetto a molti siti Internet che distribuiscono programmi di pubblico dominio e che non offrono alcuna informazione a riguardo della presenza di tecnologia adware nei software messi a disposizione per il prelevamento.
Infine, nella sezione Essenziali del cd rom forniamo sempre il software freeware Ad Aware, che può trovare ed eliminare in modo semplice e veloce i file adware e spyware presenti nel nostro sistema. Occorre però ricordare che rimuovendo tali file, i programmi adware installati che li utilizzano cessano di funzionare.


Assistenza tecnica

Pc Open mette a disposizione gratuita di tutti i lettori un servizio di assistenza tecnica.
Avendo un problema software con il computer, oppure di uso del cd rom, è possibile usare l'assistenza tecnica on line di Pc Open, all'indirizzo internet:
http://www.pcopen.it/assistenza

Occorre compilare il questionario on line per avere il diritto di porre tutte le domande che si vogliono.

Si prega di non telefonare alla Redazione per porre quesiti sul cd rom, dato che non è possibile per esigenze organizzative offrire un servizio di assistenza tecnica telefonica diretta a tutti i lettori. L'unica assistenza tecnica, ad eccezione di quanto necessario per sostituire cd rom fisicamente danneggiati, è online.

La redazione di Pc Open non risponde riguardo ai problemi d'uso dei programmi e non fornisce informazioni sulle modalità d'acquisto e di registrazione dei programmi registrati. Per avere queste informazioni, bisogna contattare direttamente i produttori dei programmi, i cui indirizzi sono di regola pubblicati nelle istruzioni che accompagnano tutti i programmi sul cd rom oppure nei programmi stessi.


Cambiare modo video

Sono disponibili varie procedure per cambiare modo video con Windows 95, 98 e Millennium.
Per usare un sistema standard ed universale, basta cliccare col pulsante destro del mouse su una parte dello schermo di Windows in cui è visualizzato lo sfondo (ovvero, dove non c'è alcuna finestra o icona),
Nel menu che appare accanto al puntatore del mouse, scegliere la voce Proprietà.
Appare un pannello chiamato Proprietà - Schermo. Cliccare la linguetta Impostazioni.
Qui appare un pannello che riporta un cursore sotto la voce "Area dello schermo". Spostando col mouse tale cursore è possibile variare il numero di punti a video (pixel) usati.
Sotto la voce Colori, invece, appare il numero di colori utilizzabili per la risoluzione video (area dello schermo) utilizzata.
Si noti che ambedue i valori dipendono dalle caratteristiche della scheda grafica usata, compresa la quantità di memoria video di cui dispone. Maggiore è la quantità di memoria video della scheda grafica, maggiore sarà il numero di colori utilizzabile a risoluzioni video più elevate.
Inoltre, la risoluzione massima utilizzabile dipende anche dal modello del monitor usato. Alcuni possono ad esempio arrivare al massimo a 800 x 600 punti, o a 1024 x 768 punti.
Si noti che variando tali parametri del modo video, con Windows 95 occorre pressoché sempre riavviare il sistema. Con Windows 98 e versioni successive è invece possibile, quasi sempre, richiedere di applicare le impostazioni senza riavviare il sistema.
Per modificare le impostazioni del font di caratteri, cliccare il pulsante Avanzate. Il primo pannello che appare, sotto la linguetta Generale, prevede la possibilità di scegliere se usare font di caratteri piccoli o grandi ("normali" in Windows XP)
Si noti che se sono installati particolari driver di controllo della scheda grafica, le medesime regolazioni possono essere ottenute a volta con altre procedure. Ad esempio, molti driver installano una piccola icona accanto all'orologio, nella barra del menu. Cliccando tale icona appare il pannello di controllo che consente di regolare risoluzione video, numero di colori e tipo di font di caratteri. Fare riferimento alla documentazione della propria scheda grafica in questo caso.


Che cosa fare in caso di problemi

I problemi che possono incontrarsi nell'uso del cd rom di Pc Open si dividono in due categorie:
problemi dovuti a difetti meccanici del cd rom
problemi dovuti all'uso dei programmi
Cliccare su una delle due voci per avere informazioni sulla soluzione di questi problemi.


Shareware e Freeware

Il termine shareware indica genericamente il software di pubblico dominio. In realtà, "pubblico dominio", "shareware" e "freeware" non significano esattamente la stessa cosa.
Un software è genericamente definibile come "di pubblico dominio" quando il produttore lo distribuisce lungo canali di larga diffusione, come ad esempio banche dati, Internet o cd rom omaggio e non lo commercializza nei canali tradizionali, che portano ai negozi.
Lo shareware è, più specificamente, materiale (in genere programmi, ma possono essere anche font di caratteri, archivi, immagini, file sonori e altro ancora) che viene diffuso per mezzo di canali accessibili da molte persone, ma sul quale l'autore detiene una proprietà intellettuale ed i diritti di sfruttamento commerciale. Questo significa generalmente che l'autore distribuisce il programma per fare conoscere e provare il proprio lavoro gratuitamente a tutti, ma che ne è comunque vietato l'uso commerciale.
I programmi shareware sono solitamente limitati nelle prestazioni. Ad esempio, poterbbero non registrare i file su disco, oppure non stampare su carta, cessare di funzionare dopo un certo tempo o avere alcune funzioni disabilitate. Questo perché l'autore richiede non solo che non se ne faccia uso commerciale, ma che gli venga corrisposto del denaro per il suo lavoro, pur lasciando la possibilità di valutare le caratteristiche del programma.
Altre volte, piuttosto rare, l'autore fornisce tutte le funzionalità al programma shareware, e lascia al buon cuore di chi lo usa di decidere se inviargli una ricompensa, pur vietandone l'uso commerciale. In questo caso appare, ad esempio, un pannello all'avviamento del programma che invita a registrarsi, ma poi il software funziona pressoché senza limitazioni. La procedura di pagamento di un programma shareware, solitamente detta registrazione, consente di ricevere una versione aggiornata e completa del programma. In alcuni casi, è anche il solo modo di avere l'autorizzazione morale all'uso del software.
Capita a volte che un programma diffuso inizialmente come shareware, goda di ampio favore da parte del pubblico e trovi dei distributori. In questo caso fortunato, è possibile acquistarne la versione completa presso il produttore, oppure un distributore europeo o nazionale.
Il software freeware è invece di uso totalmente gratuito. Anche in questo caso, molti autori richiedano di inviare liberamente, a propria discrezione, del denaro se si usa il programma, ma non obbligano a ciò gli utilizzatori con limitazioni nel programma, né forniscono versioni perfezionate o complete in cambio della registrazione. Questo genere di materiale può essere usato liberamente, sebbene non possa essere ceduto, alterato o commercializzato.
Gli autori di programmi shareware/freeware sono solitamente privati, o piccole società, che non dispongono di una rete di distribuzione. In altri casi, hanno semplicemente optato per diffondere il proprio software in modo che sia conosciuto, valutato ed apprezzato prima di richiedere del denaro a chi lo usa.
In ogni caso, leggendo la documentazione dei programmi shareware, si trovano sempre le modalità di registrazione. Quasi sempre occorre inviare del denaro contante, in busta chiusa. Altre volte è possibile pagare anche con una carta di credito. In qualche caso, i programmi particolarmente importanti possono essere acquistati presso rivenditori, talvolta presenti anche sul territorio nazionale. Nella documentazione dei programmi sono sempre riportati gli eventuali indirizzi dei rivenditori.
Per le caratteristiche dello shareware, comunque, occorre solitamente inviare il denaro direttamente all'autore. Questo consente di valutare il software prima di pagarlo e di risparmiare, saltando la catena dei rivenditori. La scomodità è che bisogna confidare nell'onestà e precisione dell'autore, che è tenuto ad inviare la versione registrata dopo avere ricevuto il denaro. Inoltre, inviare soldi contanti, in valuta estera, in una busta chiusa è un'operazione rischiosa che, come detto, solo qualche volta può essere evitata richiedendo un pagamento con carta di credito.
Va notato che in nessun caso ci si può rivolgere alla redazione di Pc Open per richiedere la versione registrata di un programma, dato che questo diritto compete sempre all'autore del programma shareware, oppure ad uno dei suoi rivenditori, riportati nella documentazione dei titoli shareware.
Infine, altri autori optano per forme più simpatiche di pagamento del loro materiale freeware. Ad esempio, il software cardware è quello per il quale l'autore richiede solo l'invio di una cartolina di saluti. Altre volte, l'autore richiede soltanto un pagamento simbolico volontario ad enti di beneficenza, se si usa il suo programma, in questo caso si parla di software careware.


Chi siamo

PC OPEN
www.pcopen.it
Direttore responsabile
Roberto Mazzoni

Realizzazione tecnica cd rom
Luigi Callegari
Grafica cd rom
Elena Manzoni
Redazione
Vincenzo Zaglio
Ugo Stella
Daniela Dirceo
Nicolò Cislaghi
Luca Moroni

Art director
Luciano Franza

Segretaria di redazione
Eleonora Castellazzi

Redazione
Via Rosso di San Secondo, 1/3
20134 Milano - Italy
Telefono: 02-21.56.24.33
Telefax: 02-70.12.03.05
redazione@pcopen.agepe.it

Responsabile diffusione e abbonamenti
Sandra Salvucci

Ufficio abbonamenti e informazioni
I.M.D.
Tel. 02-64.28.135
Fax. 02-64.28.809
pcopen@imd-emd-group.org

Direttore Divisione Informatica
Roberto Lenzi

Sales Manager
Diego Arletti

Segreteria commerciale
Irma Garioni, Anna Montuori
Tel. 02-21.56.21
Fax. 02-70.12.00.32

Prodotti e News
Daniela Giovine
Tel. 02-21.56.24.14
Fax. 02-70.12.00.32

Editore
Agepe Srl
Una società di Vivendi Universal Publishing
Via Trentacoste, 9
20134 Milano
Tel. 02-21.56.21
Fax. 02-21.58.040

Amministratore delegato
Giorgio Tonelli

Altre pubblicazioni Agepe
Al-Food & Grocery, Bargiornale, Casastile,
Computer Dealer & Var, Gdo Week, Pianeta Hotel,
Infobuyer 2000, L'ambiente Cucina,
Layout, Linea Edp, Reseller Weekly, Vini,
Reti & Impresa, Ufficio Stile, www.netstime.com


Come collaborare

Il cd rom di Pc Open è aperto alla collaborazione di lettori e case produttrici. Se si desidera inviare materiale per l'eventuale inserimento sul nostro cd rom occorre seguire una semplice procedura e sapere alcune nostre convenzioni.
Il materiale da pubblicare deve essere distribuibile liberamente e gratuitamente sul cd rom della rivista. L'autore deve pertanto inviare, insiema al materiale da sottoporre alla nostra attenzione, anche una lettera liberatoria stampata su carta e firmata. Una bozza di tale documento, adatta per la dichiarazione di un privato, potrebbe essere di questo tipo:
Io sottoscritto, _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _, nato a _ _ _ _ _ _ _ _ _ _ il _ _ _ _ _ _ _ ed attualmente residente a _ _ _ _ _ _ _ _ _ _ _, in via _ _ _ _ _ _ _ _ _ invio i seguenti programmi per l'eventuale inserimento sul cd rom accluso alla rivista Pc Open, edita da Agepe Srl: _ _ _ _ _ _ _(citare i programmi per nome) _ _ _ _ _ _ _ _ _ _ _ _ _ _ _.
Dichiaro che tale materiale è di mia originale ideazione e programmazione e che non comprende parti soggette a copyright o comunque di proprietà di terzi, sui quali non ho facoltà di libera ridistribuzione. Dichiaro inoltre che il software suddetto non contiene file multimediali sonori o musicali di produzione mia o altrui, né comunque produce contenuti multimediali. Con la presente autorizzo Agepe Srl, senza ulteriori condizioni, alla pubblicazione di tale materiale nel cd rom accluso alla rivista Pc Open per la distribuzione sul territorio nazionale.
Dichiaro di essere consapevole che in questo modo i miei programmi verranno messi a disposizione di tutti i lettori della stessa rivista. Dichiaro altresì di essere a conoscenza del fatto che Agepe Srl non remunera compensi per l'inserimento di software di questo tipo sul cd rom accluso alla rivista Pc Open, rinunziando pertanto, in modo irrevocabile, ad ogni richiesta di commissione o di remunerazione per la pubblicazione del materiale che ho inviato. I programmi saranno pubblicati, ad insindacabile giudizio della redazione di Pc Open, nei modi e nei tempi dettati dalle esigenze editoriali e di produzione del cd rom.
Ai sensi dell'art.10 della Legge 675/1996, le finalità del trattamento dei dati relativi ai destinatari consistono nell'assicurare una informazione tecnica, professionale e specializzata a soggetti identificati per la loro attività professionale. L'editore, Agepe Srl, titolare del trattamento garantisce ai soggetti interessati i diritti di cui all'art. 13 della suddetta Legge. Responsabile del trattamento dati: Maurizio Ballerini.
(Firma leggibile)
Società che desiderano proporre propri programmi sono pregati di compilare una lettera liberatoria simile a quella riportata su carta intestata, firmata da una persona con riportato, in chiaro, nome, cognome e carica legale nella società stessa.
E' anche gradito sapere se il materiale spedito è stato sottoposto all'attenzione di altre testate, o se è già stato distribuito in altro modo (banche dati, Internet, raccolte shareware eccetera).
NOTA BENE: in base alle recenti normative sulla tutela del Diritto d'Autore da parte di S.I.A.E., non possiamo pubblicare sul cd rom della rivista programmi che contengano animazioni video (in qualunque formato, tipo Avi, Quicktime, Mpeg ecc.) né colonne sonore costituite da brani musicali riprodotti da file sonori (tipo Mp3, Wav, Midi ecc.) o prodotti comunque dal codice del programma.
Ricordarsi di specificare sempre con chiarezza il proprio indirizzo, numero di telefono ed eventuale indirizzo E-mail.
DOCUMENTAZIONE DA FORNIRE PER LA PUBBLICAZIONE
Il materiale spedito deve essere completo dei programmi eseguibili e di file di testo con la documentazione, scritti in un formato visualizzabile da qualunque utente di Windows (95, 98, Me, 2000 o Xp). Per questo, basta usare programmi come il Wordpad di Windows e registrare i file preferibilmente in formato RTF.
Nella documentazione a cura dell'autore del programma inviato, fornita dall'autore, devono anche essere ben chiare le seguenti informazioni:
1) Requisiti minimi del sistema per il corretto funzionamento del software inviato, in termini di hardware e sistema operativo.
2) Spazio richiesto su disco e modalità di installazione e di disinstallazione.
3) Le eventuali limitazioni introdotte nel software fornito per la pubblicazione rispetto a versioni commerciali/registrate.
4) Un eventuale indirizzo di email, o altre coordinate (numero telefonico/fax/indirizzo postale) al quale i lettori possono rivolgersi per informazioni.
L'ideale è fornire un file in formato testo simile a quello che accompagna tutti i programmi nel nostro cd rom (chiamato Testo.rtf e collocato nella cartella di installazione del programma). Il software deve essere installabile avviando un file in una cartella isolabile e collocabile in qualunque sotto cartella nella struttura del nostro cd rom.
Specificare sempre, inoltre, a chi bisogna rivolgersi per ottenere chiarimenti sul suo funzionamento o per eventualmente acquistare una versione registrata/completa. Sono ben accetti indirizzi di posta elettronica e siti Web. In questo modo si intende che non sarà la Redazione di Pc Open, ma l'autore, a rispondere ad eventuali quesiti da parte dei lettori della rivista.
Così come i privati, anche le aziende che volessero inserire versioni dimostrative di prodotti commerciali, o materiale promozionale, dovrebbero contattare la redazione di Pc Open per corrispondenza, E-Mail Internet o per telefono:
Pc Open
Via Rosso di San Secondo, 1/3
20134 Milano
Telefono: 02-21.56.24.33
Telefax: 02-70.12.03.05
E-mail: redazione@pcopen.agepe.it
Allo stesso indirizzo deve essere inviato il materiale per la valutazione ed ogni eventuale corrispondenza riguardante l'inserimento di materiale sul cd rom di Pc Open. Tutto il materiale inviato dai lettori viene valutato con attenzione e, se meritevole ed interessante, viene pubblicato sul primo o secondo cd rom tecnicamente raggiungibile.
Per abbreviare i tempi, è anche possibile inviare il materiale da esaminare per un'eventuale pubblicazione all'indirizzo Internet:
cdrom@pcopen.agepe.it
in ogni caso, è necessario stampare su carta, compilare, firmare e spedire alla Redazione il modulo sopra riportato di autorizzazione alla pubblicazione.
Se il software inviato non comprende la documentazione sopra specificata e il modulo di liberatoria compilato e firmato, non sarà possibile procedere alla sua pubblicazione. Non sono considerate accettabili lettere di liberatoria che non pervengano firmate su carta, per telefax o posta ordinaria.


Come creare le icone

Quando un programma è privo della procedura di installazione, è solitamente necessario copiarlo sull'hard disk e poi lanciarlo con un doppio click del Gestione Risorse di Windows 95 o di Esplora Risorse di Windows 98 e Millennium.
Per comodità, è possibile comunque creare delle icone, che consentano di lanciare con un doppio click dal pannello principale del programma, senza dovere "navigare" tutti i contenuti dell'hard disk. La procedura è semplice e nota a molti, ma la ripetiamo qui a beneficio dei meno espterti.
In ambiente Windows 95, 98 2000 e Me la procedura di inserimento di un'icona la crea nel menu Start/Avvio. Occorre selezionare il menu Avvio, poi scegliere Impostazioni e quindi la voce Barra delle Applicazioni.
Scegliere quindi con un click la linguetta superiore Applicazioni del menu Avvio e cliccare il pulsante Aggiungi. Appare così un pannello chiamato Crea collegamento.
Cliccare il pulsante Sfoglia e localizzare sull'hard disk il file eseguibile (contraddistinto dal suffisso .exe, .com o .bat nel nome) interessato.
Poi cliccare Avanti: appare il pannello "Seleziona il gruppo di programmi". Qui occorre indicare con un doppio click in quale posizione della struttura attuale del menu Avvio si desidera inserire l'icona.
Proseguire con Avanti. Nel pannello Specifica il nome dell'applicazione indicare il nome dell'applicativo che comparirà nel menu Avvio. Se si è scelto un programma privo di icona, apparirà poi un pannello che consente di sceglierne una tra quelle "universali" inserite in Windows 95/98.
Altrimenti è sufficiente confermare l'operazione cliccando il pulsante <Fine>. Avremo così creato una nuova voce nel menu Programmi, nella posizione voluta, con il nome voluto, che avvia il programma localizzato col pulsante <Sfoglia>. Ovviamente, non si deve specificare un programma su cd rom, ma preferibilmente su hard disk, altrimenti ogni volta dovremo inserire il cd rom per avviarlo da menu.
Eliminazione delle icone dal menu Start/Avvio
Selezionare con un click il menu Avvio. Scegliere poi la voce di menu Impostazioni e la sua sottovoce Barra delle Applicazioni. Appare un pannellino chiamato Proprietà della barra delle applicazioni. Cliccare sulla linguetta superiore Applicazioni del menu Avvio, quindi cliccare il pulsante Rimuovi. Nella struttura grafica del menu Start/Avvio, selezionare con un click le icone da eliminare, poi cliccare il pulsante Rimuovi.
Creazione di un'icona sul desktop
Un altro modo per avviare velocemente un applicativo è di creare un'icona di collegamento al programma sullo schermo di Windows, il cosiddetto Desktop. Il modo più semplice per creare un collegamento è di aprire la cartella che contiene il programma, indiviuare l'icona corrispondente al programma eseguito, trascinarla usando il pulsante DESTRO del mouse dalla cartella di memorizzazione allo schermo di Windows. Quando la si "appoggia" sul desktop, rilasciando il pulsante destro, apparirà un menu che chiede se vogliamo eseguire la copia, lo spostamento o un collegamento. Scegliere quest'ultima voce.
Un collegamento sul desktop si cancella semplicemente trascinandolo nel cestino, selezionandolo con un click del pulsante destro del mouse e scegliendo poi "Elimina" o cliccandolo una volta col pulsante sinistro e battendo <Canc> sulla tastiera.


Condizioni d'uso

Il cd rom di Pc Open, offerto in omaggio con la rivista e non acquistabile separatamente, viene prodotto con la massima cura in tutte le fasi di produzione e duplicazione per garantire la mancanza di difetti tecnici e materiali.
Il materiale originale ed i titoli di pubblico dominio inseriti nel cd rom sono di proprietà dei rispettivi autori, pertanto sono protetti dalle leggi italiane e internazionali sul diritto d'autore e la proprietà intellettuale. Ogni utilizzo non espressamente autorizzato sarà perseguito in sede Civile e Penale.
L'Editore, i suoi dipendenti e collaboratori non possono essere ritenuti responsabili per errori, omissioni ed altre imprecisioni riguardanti le informazioni ed il materiale presentato sul cd rom, né possono essere ritenuti responsabili per qualunque tipo di danno, diretto od indiretto, particolare o accidentale o conseguenziale, derivante dall'uso del cd rom e dei suoi contenuti.
Data la grande varietà e complessità dei sistemi informatici e le caratteristiche del software, è assolutamente impossibile garantire che tutti i contenuti del cd rom funzionino correttamente, su ogni tipo e configurazione di personal computer ed in ogni circostanza. I programmi ed il materiale sul cd rom sono pertanto forniti in omaggio ed "allo stato attuale", senza nessuna garanzia implicita od esplicita sulle loro prestazioni, compatibilità, funzionalità e correttezza.
Si suggerisce di eseguire un backup della configurazione del personal computer prima di usare il cd rom e di evitarne l'uso in sistemi connessi ad una rete o contenenti dati importanti in singola copia.
L'Editore, i suoi dipendenti e collaboratori non possono in alcun caso essere ritenuti responsabili per corruzioni o perdite di dati, mancati profitti o per ogni altro possibile dato causati, direttamente od indirettamente, dall'uso del cd rom e dei suoi contenuti.
Leggere attentamente anche le clausole d'uso contenute nel programma di avviamento del cd rom prima di iniziare la consultazione ed installarne i contenuti.


Consigli per l'installazione

Quando si installa un programma in Windows, quasi sempre non si esegue soltanto una copia di file su disco fisso, in una cartella ben specificata.
Infatti, per le caratteristiche di funzionamento del sistema operativo, è necessario spesso modificare alcuni suoi file (detti "di sistema"), copiare file di supporto in cartelle speciali di Windows, diverse da quelle di installazione, ed eseguire operazioni quali la creazione delle icone nel menu Start/Avvio o in altri punti del sistema, quali la barra di menu, il pannello di controllo e così via.
Ciò significa che installando parecchi programmi in Windows, si finisce con l'alterare profondamente la sua struttura, rispetto ad un sistema "ottimale" appena installato, privo di qualsiasi applicativo. Per certi versi, Windows può risentire dell'installazione di parecchi applicativi.
La cosa diventa particolarmente evidente quando si è soliti installare ogni mese parecchi programmi, prelevandoli da Internet o da cd rom come quelli di Pc Open o altre riviste. Sebbene i software da noi presentati vengano accuratamente verificati nelle caratteristiche e nel funzionamento per escludere quelli che possono dare problemi, se si installano decine di programmi anche "perfetti" tecnicamente, si finisce con il lasciare tracce della loro presenza in Windows.
Disinstallazioni imperfette
La cosa viene aggravata dal fatto che molte procedure di disinstallazione, sia di programmi commerciali che di programmi di pubblico dominio, non sono perfette. Abbandonano file nelle cartelle di sistema di Windows, lasciano piccole modifiche ai suoi file di sistema, non ripristinano file eventualmente sostituiti con versioni più recenti o in lingua diversa da quelli pre-esistenti durante l'installazione e così via. Quasi sempre di tratta di piccole cose, ma moltiplicandole per decine di software, gli effetti negativi su Windows, alla lunga, possono diventare evidenti.
Le conseguenze più gravi sono messaggi di errore all'avviamento di Windows (file mancanti), blocchi di sistema durante operazioni "innocue", malfunzionamento di alcuni programmi ed altro ancora.
Il rimedio finale è uno solo: reinstallare Windows 95, 98 o Millennium daccapo. Gli utenti di Windows 98/Me hanno in effetti una possibilità in più. Usare la voce Microsoft System Information del menu Accessori/Utilità di sistema. Scegliendo la funzione Controllo file di sistema si possono ripristinare i file modificati, danneggiati o cancellati rispetto all'installazione originale di Windows. Occorre disporre del cd rom di installazione originale per fare leggere i file da ripristinare se si usa Windows 98, mentre Windows Me tiene una copia dei file di installazione sul disco fisso.
Prudenza!
Per evitare questi problemi il più possibile, occorre seguire alcune regole quando si installano programmi, di pubblico dominio o commerciali, sul proprio computer. Il massimo della prudenza, che vale anche se non si installa mai nulla, è eseguire una copia di sicurezza almeno una volta alla settimana dei file importanti. Basta usare una cartella del disco fisso, o meglio una memoria di massa (dischi Imation, Jaz, Zip, Syquest, cartucce di streamer, Dat ecc.) per mettere al sicuro di tanto in tanto i file di lavoro: contabilità, lettere, fax, posta elettronica. Se lo spazio sulla memoria di massa lo rende possibile, si può anche mettere al sicuro l'intero disco di lavoro con Windows: occorrono però di solito centinaia di megabyte.
Quando si installa un programma nuovo, seguire poi alcune semplici regole di prudenza:
1) Non usare mai software scritti per Windows 3.1 (o "anche" per esso) in Windows 95, 98 o Me. Molti dei cd rom regalati da quotidiani, riviste e stampa non specializzata rientrano in questa categoria. Questo genere di programmi danneggia spesso Windows 95/98/Me perchè ne va a modificare i file di sistema con versioni più vecchie. Windows Millennium impedisce comunque l'installazione di programmi di questo tipo, così come Windows 2000.
2) Non sovrascrivere mai durante l'installazione file già esistenti con versioni più vecchie o in lingua diversa, se ciò viene richiesto.
3) Non installare mai componenti non necessari. Molti cd rom acclusi a riviste, quotidiani e offerti in via promozionale, ad esempio, installano (a volte senza richiederci nemmeno il permesso...) programmi non sempre necessari come Apple Quicktime, Microsoft Video for Windows, Microsoft Explorer versione 3 o 4, e così via. Se si dispone di un sistema Windows 95/98/Me aggiornato, con il più recente Windows Media Player e Explorer (li trovate sempre nel cd rom di Pc Open), tutti questi programmi non sono necessari. Installandoli comunque si ottiene al minimo di sprecare spazio sul disco, più probabilmente si ottiene anche di danneggiare le funzioni multimediali di WIndows, con conflitti di versione, file di sistema scorretti e così via. Particolarmente nocivo è anche lasciare installare un nuovo browser se si è configurato un Explorer, o Navigator, per svolgere le funzioni di lettura di file Html e relativi contenuti multimediali.
4) Per rimuovere un programma dopo averlo provato, usare sempre la sua funzione di disinstallazione. In genere è presente un'icona , oppure una voce nel Pannello di Controllo, nella finestra che appare cliccando l'icona Installazione Applicazioni. Non cancellare mai a mano la cartella di installazione: questo non solo non elimina le modifiche apportate dal programma al sistema durante l'insatallazione, ma ne impedisce del tutto una successiva corretta rimozione.
5) Se si usano spesso programmi shareware e/o si è soliti provare vari programmi, procurarsi uno strumento di disinstallazione e manutenzione del sistema. Tra i più famosi in Italia, facilmente reperibili in commercio, vi sono Cybermedia Uninstaller e Symantec Cleansweep. Questi possono non solo eliminare in modo più completo software dotati di procedure di disinstallazione imperfette, ma anche quelli che ne sono privi. Inoltre consentono di eseguire una manutenzione dei file di sistema di Windows che ne permette di mantenere intatta la velocità e funzionalità nel tempo, senza doverne ripetere l'installazione.
Aggiornamenti
Quando si esegue l'aggiornamento di un programma già installato, ad esempio dalla sezione Essenziali, occorre prestare particolare attenzione. Molti programmi, infatti, non cancellano la versione precedente e si installano "a parte". Questo può essere utile se si desidera conservare la vecchia versione, soprattutto nel caso in cui quella nuova ci desse dei problemi o ci piacesse di meno...
In ogni caso, soprattutto quando si installano programmi che personalizzano funzioni importanti di Windows, è sempre consigliabile procedere alla disinstallazione della versione precedente del programma prima di procedere all'installazione di quella nuova.
Il discorso è ancora più delicato se installiamo la versione "a scadenza" o dimostrativa di un programma del quale abbiamo già installato la versione completa, acquistata in negozio o registrata presso l'autore. In questo caso, è bene evitare di installare la nuova versione: in alcuni casi quella completa portebbe cessare di funzionare o mostrare problemi di funzionamento, costringendoci alla totale disinstallazione di ambedue le versioni prima di ripetere l'installazione di quella completa.
Riavviare
Altro consiglio importante è che quando si disinstalla un programma, sarebbe sempre meglio riavviare Windows prima di proseguire ad utilizzarlo, soprattutto prima dell'installazione di altri nuovi programmi. Questo è particolarmente prezioso quando si installano, come detto poco sopra, aggiornamenti di versioni di programmi già installati. Infatti, in alcuni casi file ed impostazioni vengono effettivamente rimossi dopo il riavviamento totale di Windows. Procedendo subito all'installazione di una nuova versione può significare in questo caso "confondere" Windows.


Il backup

Sebbene i programmi inseriti sul cd rom siano sempre tutti quanti verificati e provati, per garantire la loro funzionalità, su più sistemi WIndows, non è escluso che eseguendo l'installazione di uno di essi, come di qualunque altro programma anche commerciale, non si danneggi qualcosa nel proprio sistema. Intendiamo ovviamente danneggiamenti software, perché nessun software può danneggiare l'hardware del nostro personal computer.
Windows nelle versioni 95, 98, Millennium, XP e 2000 tende infatti a diventare "instabile" se si installano vari programmi. In particolare, sebbene i programmi per Windows 3.1 siano compatibili con le successive versioni di Windows a 32 bit (eccetto Windows 2000), alcuni software male preparati (anche commerciali) possono sovrascrivere dei file di sistema con versioni più vecchie e non adatte a Windows 95/98, causando in seguito, con le altre applicazioni in Windows 95/98, problemi di funzionamento o addirittura blocchi del sistema. Windows Millennium e 2000 precludono comunque l'installazione di applicativi che non rispettino certi standard di sicurezza sulla sovrascrittura dei file di sistema.
Inoltre, una mancanza di tensione, l'operazione errata di qualunque programma o altre situazioni accidentali possono danneggiare file di sistema di Windows e quindi la sua stabilità. La conseguenza può essere immediata o apparire dopo qualche tempo. Spesso, questi problemi appaiono poi installando qualche nuovo programma.
Eseguire il cosiddetto "backup" significa mettersi al riparo da spiacevoli perdite di dati. In particolare, qualunque dato importante (ad esempio, le proprie lettere o la contabilità) andrebbero regolarmente salvate su una memoria diversa dall'hard disk interno del computer. Esistono molte unità di backup: gli streamer (basati su nastrini magnetici simili alle audiocassette), Dat (come i precedenti, ma digitali e più capaci), dischi rimuovibili Zip, Jaz Syquest, hard disk esterni, dischi magneto ottici e altro ancora.
Se non si dispone di alcuno di questi sistemi, usare sempre molta prudenza e cerrcare di evitare l'installazione di nuovi programmi se non si è prima eseguita almeno su floppy disk il salvataggio dei file più importanti del proprio computer: corrispondenza realizzata con la videoscrittura, fax ricevuti, dati della contabilità eccetera.
La cosa migliore, prima di eseguire installazioni di nuovi programmi, è di eseguire un backup del proprio sistema Windows. E' sufficiente copiare tutta la cartella Windows sull'unità di backup. Naturalmente, questa operazione è pressoché impossibile se si usano floppy disk, dato che anche una installazione minima di Windows con qualche applicativo potrebbe richiederebbe, per il backup, decine e persino centinaia di floppy ed un'operazione estremamente lunga e tediosa.
Windows 95, 98, Me e 2000 sono provvisti di programmi di backup che possono funzionare con floppy disk. La versione per Windows 9x, Me e XP consente di usare anche cartucce di stramer o di salvare su un unico file compresso di backup i contenuti delle cartelle più importanti. Per usare questi programmi, fare riferimento ai manuali di istruzione del sistema operativo usato.
Il problema dell'installazione di nuovi applicativi che possano rovinare i file di sistema di Windows è sensibilmente ridotto con Windows ME, XP e 2000. Questi sistemi operativi, infatti, dispongono di due meccanismi di protezione: possomo ripristinare la configurazione originale dei file ad una certa data e proteggono i file di sistema dalla sovrascrittura, ripristinando le versioni originali in modo trasparente all'utente ("PC Health").
Ripetiamo che è fortemente consigliabile usare unità di memoria adatte, come streamer a nastro o Dat, dischi Zip, Jaz o Imation Superdisk, dischi magneto ottici e simili per eseguire il backup in modo rapido e efficiente di grosse moli di dati.


Interfaccia del cd rom

L'interfaccia grafica di consultazione del cd rom di Pc Open è stata studiata e realizzata per risultare semplice, affidabile ed intuitiva da usare. E' realizzata in formato Html, seguendo il più possibile gli standard internazionali. E' ottimizzata per un modo video di almeno 800 x 600 punti, con 32 mila colori e per l'uso con Microsoft Internet Explorer 5 o 6. SI possono naturalmente usare altri browser, ma in questo caso si potrebbero sperimentare lievi difetti di visualizzazione dei componenti della pagina

Oltre al browser, installato e configurato, il modo video deve essere di almeno 800 x 600 punti video, altrimenti l'interfaccia non funziona.Per consultare i contenuti del cd rom e per installare i programmi presentati non è necessario collegarsi ad Internet, dato che tutti i file necessari sono sul cd rom stesso.
Alcuni servizi forniti dal cd rom possono invece richiedere la connessione ad Internet. In questo caso, però, verrà specificato chiaramente dall'interfaccia del cd rom.

Una caratteristica molto importante della nostra interfaccia grafica è che non richiede l'installazione di alcun file sull'hard disk. Quindi, non occupa spazio e non altera in alcun modo il sistema operativo, pur consentendo di esaminare i contenuti del cd rom. Una garanzia di affidabilità e sicurezza che mette al riparo gli utenti che vogliono sapere che cosa c'è sul cd rom senza rischiare di alterare il sistema operativo di un personal usato per lavoro o contenente dati importanti e di dovere usare in seguito, quando il cd rom è diventato vecchio, procedure di disinstallazione e manutenzione manuale per "ripulirlo" dalle icone e dai file non più voluti.

Soltanto quando si clicca l'icona di installazione di uno specifico titolo, viene avviata una procedura standard che esegue la copia dei file dal cd rom al nostro hard disk, apportando anche eventuali modifiche al sistema Windows.


I virus

Il cd rom di Pc Open viene realizzato con la massima attenzione per evitare di inserire virus informatici.
Innanzitutto, i sistemi sui quali viene sviluppato sono protetti costantemente da sistemi antivirus residenti. Quasi giornalmente viene eseguita anche una scansione approfondita di tutti i file di sistema, con le ultime versioni di vari antivirus, regolarmente aggiornati.
Al termine della realizzazione del cd rom, viene ripetuta la scansione di tutti i contenuti del cd rom stesso, sempre con vari antivirus ed in varie modalità di analisi. Ovvero, il gold disk destinato alla duplicazione viene scandito dal software antivirus con i database di ricerca dei virus più aggiornati possibili, poi anche con la cosiddetta ricerca euristica, che consente di intercettare con ottima probabilità anche forme virali pressoché sconosciute.
Va precisato che le fonti di approvigionamento dei nostri programmi sono in larga misura garantite, corrispondendo di solito ai siti Internet od alle banche dati ufficiali dei produttori dei programmi. In ogni caso, qualunque file e programma che producesse messaggi di avvertimento da parte di uno o più antivirus aggiornati, tra i cinque diversi tipi che usiamo regolarmente, verrebbe inesorabilmente scartato e non inserito sul cd rom di Pc Open, per garantire la massima sicurezza ai lettori.
Quando il gold disk originale viene inviato alla ditta per la duplicazione industriale, si può stare certi che si tratta di un prodotto sicuro, per quanto l'uso coordinato ed attento di sistemi antivirus residenti, a scansione e sempre costantemente aggiornati, possono garantire.
Dato l'elevato numero di virus in circolazione e la continua produzione di nuove forme, è impossibile escludere totalmente che qualunque tipo di virus, presente e futuro, sia inserito per errore sul cd rom.
Per questo motivo nelle clausole di utilizzo si declina ogni responsabilità a riguardo e si sconsiglia di utilizzare il cd rom in sistemi medicali e di importanza vitale. Se si dispone di un antivirus aggornato, è possibile per avere il massimo di sicurezza possibile (anche se non sarà mai al 100%) ripetere la scansione del cd rom prima di utilizzarne i contenuti.
A tutt'oggi, nessun virus è mai stato inserito su un nostro cd rom. Un fatto che sarebbe estremamente grave e per il quale, come appena visto, adoperiamo sempre la massima prudenza ed attenzione in ogni fase della produzione.
Può capitare che alcuni lettori scandiscano con un antivirus il cd rom, ottenendo dei messaggi di avvertimento del sospetto di presenza di virus in qualcuno delle migliaia di file che ne costituiscono i contenuti. Possiamo rassicurare queste persone con le note prima riportate.
Per ulteriore conferma, li invitiamo normalmente a procurarsi una versione più aggiornata degli antivirus che usano e ripetere la verifica. Di regola, le segnalazioni scompaiono. In caso contrario, evitare di usare il cd rom.
Va detto comunque, che l'uso di scanner antivirus, in particolare quelli con ricerca euristica, possono confondere sequenze di codici ignoti "innocue" per virus. Ma ripetendo l'analisi con una versione più aggiornata, e con antivirus di altre marche, si dovrebbe notare che nessun file del cd rom di Pc Open viene segnalato essere sospetto. E' molto difficile, infatti, che sul cd rom venga inserito un file con un virus così nuovo da non essere intercettato dai nostri antivirus, anche se, ciò non può essere escluso totalmente a priori.
Verificare, per sicurezza, che il virus sia effettivamente segnalato in un file di programma o compresso. La segnalazione di un virus in un file di tipo .Jpeg, ad esempio, sarebbe sicuramente un falso allarme perché nessun virus si colloca in un tipo di file che non viene eseguito!
Inoltre, se dopo l'uso del cd rom di Pc Open si riscontra la presenza di un virus, molto difficilmente questo può derivare dal nostro cd rom, ma probabilmente era presente nel proprio sistema precedentemente oppure è stato inserito da qualche programma o dischetto usato subito prima o dopo il cd rom di Pc Open.
In questo caso, usare un antivirus commerciale o registrato, oppure rivolgersi a persone competenti, per eseguire la pulizia dell'hard disk e verificare anche i dischetti usati negli ultimi tempi, che potrebbero essere stati infettati.


Problemi hardware

Il cd rom di Pc Open viene prodotto con la massima cura e duplicato da aziende specializzate, conformi ai più rigidi standard qualitativi europei.
Può comunque capitare che, su moltissime unità duplicate, qualche cd rom accluso alla rivista subisca danneggiamenti durante il trasporto, il confezionamento oppure l'esposizione in edicola. In questo caso, il cd rom può risultare parzialmente o totalmente illeggibile. Nel primo caso il computer fornirà messaggi di errore cercando di accedere a certi file e programmi, nel secondo caso il cd risulta vuoto o viene addirittura espulso dal lettore di cd rom.
In questi casi, per prima cosa occorre accertarsi che sia proprio il cd rom ad essere difettoso e non il personal computer che abbia problemi di configurazione. La soluzione migliore è verificare che la superficie inferiore sia perfettamente pulita, poi tentare di usare il cd rom su un sistema diverso, ad esempio quello di un amico o di un collega.
Se il difetto non si ripete, è chiaro che dipende dal nostro computer. In questo caso occorre verificare l'allineamento della testina di lettura del cd rom, che potrebbe risultare incompatibile con i rigidi standard di duplicazione usati dal nostro cd rom. Oppure potrebbe essere un problema di configurazione di Windows. Consultare in ambedue i casi chi ci ha fornito il computer o persone competenti. Questo genere di problemi può infatti essere risolto solo intervenendo in modo diretto e competente sul personal computer.
Se il cd rom risulta invece ancora inutilizzabile, anche su un diverso sistema che abbia comunque i requisiti minimi necessari, probabilmente è difettoso meccanicamente. In questo caso, si può richiedere una sostituzione gratuita. Occorre però tassativamente rinviare il cd rom da sostituire dentro una busta chiusa, con una nota scritta che segnali esattamente il problema riscontrato ed il proprio indirizzo completo.
A stretto giro di posta, sarà rinviato un cd rom uguale a quello spedito e sicuramente funzionante. L'indirizzo al quale spedire il cd rom difettoso è il seguente:
Agepe Srl
Ufficio Diffusione
Via Trentacoste, 9
20134 Milano MI
Italy
Per informazioni in caso di problemi, è consigliabile contattare preventivamente l' assistenza tecnica .
Agepe sostituirà il cd rom difettoso a sua discrezione e soltanto nel caso venga rinviato postalmente entro sessanta giorni dalla data di uscita della rivista alla quale era accluso.
Si noti che la sostituzione gratuita viene eseguita soltanto se il cd rom è difettoso meccanicamente. Non si sostituiscono cd rom che contengano soltanto uno o più programmi non funzionanti sul proprio sistema.
Nel caso si abbiamo problemi nell'uso di certi programmi, o dell'interfaccia grafica, è consigliabile innanzitutto contattare gli autori o produttori, i cui indirizzi sono riportati nelle istruzioni in italiano che corredano tutti i programmi presentati, oppure direttamente nel menu di guida (Help) dei programmi.
La nostra assistenza tecnica risponde solo di problemi tecnici di compatibilità e funzionamento del cd rom, non dei suoi contenuti. Va contattata in ogni caso per evitare un'inutile e costosa spedizione di un cd rom funzionante ed i cui problemi derivano effettivamente dal nostro sistema, o da qualche nostro errore operativo e che pertanto non potrebbero essere superati con la semplice sostituzione del cd rom con un pezzo identico e funzionante allo stesso modo.


Problemi software

Per le caratteristiche di software gratuito dello shareware, è impossibile garantire che tutti i programmi forniti sul cd rom funzionino perfettamente, con qualunque sistema informatico ed in ogni circostanza e configurazione.
Ogni programma presentato viene da noi verificato su diversi sistemi, per garantire che funzioni, ragionevolmente, su tutti i sistemi informatici correttamente configurati e funzionanti. Tuttavia, in specifiche configurazioni, o con certi altri programmi installati, si possono avere incompatibilità che pregiudicano l'uso di qualche titolo presentato.
Prima di sospettare che un programma non funzioni, con il proprio computer, leggere con molta attenzione le istruzioni che sono sempre fornite per ogni programma.
In molti casi, si potrebbe avere un sistema inadatto, oppure può occorrere qualche procedura particolare prima di usare il programma, come l'installazione di driver, la copia dei file su hard disk ed altro ancora. Tutto viene comunque spiegato nelle istruzioni che appaiono cliccando sull'icona a forma di libricino nell'interfaccia grafica di consultazione. Bisogna solo avere la pazienza di leggerle attentamente prima di installare od usare il programma.
Quando si usano sistemi con poche risorse (memoria video, ram eccetera) libere, è possibile che l'uso dell'interfaccia grafica per avviare certi programmi dia problemi. In questo caso, è consigliabile chiudere l'interfaccia grafica, recuperando risorse del sistema, avviando poi il programma con una procedura manuale.
Nelle istruzioni di ogni programma si precisa sempre che cosa si deve fare per avviare un programma sul cd rom usando il Gestione Risorse di Windows 95/98. Infatti, viene sempre specificata la cartella sul cd rom dove è collocato il programma di installazione, od avviamento manuale, che può essere eseguito senza usare l'interfaccia grafica.
Se i problemi d'uso dei contenuti o dell'interfaccia grafica del cd rom persistono, è sempre possibile inviare il servizio di assistenza tecnica on line di Pc Open, all'indirizzo:
http://www.pcopen.it/assistenza


Requisiti di sistema

I cd rom di Pc Open vengono realizzati in formato singola sessione, ISO 9660 e con nomi di file e directory in standard Joliet, ovvero costituiti al massimo da 8 caratteri Ascii più 3 caratteri di suffisso (opzionali) per i programmi Dos e con nomi estesi per i software specifici di Windows 9x, Me, 2000 e XP.

Questo significa che i suoi contenuti possono essere visti su qualunque sistema dotato di un lettore di cd rom standard (non importa il modello o le prestazioni, da 2X a 50X varia solo la velocità di lettura) dotato di sistema operativo Ms Dos versione 3.30, Windows 95, 98, Me, 2000 e MacOs. I contenuti del cd rom sono per sistemi Windows a 32 bit (95, 95, Me, 2000), pertanto usando Ms Dos, Windows 3.1 o sistemi Macintosh i nomi dei file potranno apparire spezzati, pur rimanendo i file di dati (ad esempio, quelli con suffisso Pdf o Rtf) leggibili con tali sistemi.

Per usare l' interfaccia grafica del cd rom, ovvero il sistema di consultazione del cd rom, realizzato in formato HTML (come i contenuti delle pagine del Web), occorre invece un sistema con requisiti minimi che corrispondono anche a quelli necessari per potere usare la gran parte del software di pubblico dominio presentato:
Microprocessore di classe Pentium
 Almeno 32 MB di memoria ram (64 MB per WIndows Me/2000)
 Scheda grafica Super Vga
 Modo video di almeno 640 x 480 punti, con almeno 32 mila colori e font di caratteri piccoli
 Mouse
 Lettore cd rom almeno 4X (standard MPC 2)
 Sistema operativo Windows 95, 98, Millennium, 2000, XP
Font di caratteri piccoli ("normali" in Windows XP)
Browser Microsoft Internet Explorer 5 o 6 (consigliato)

Il browser deve essere configurato ed installato, anche con una connessione "fittizia", per potere caricare il file Html nella cartella principale del cd rom.

Si noti che può capitare che alcuni programmi tra quelli presentati, possono funzionare anche con personal inferiori, in termini di potenza, o addirittura con sistemi operativi Dos e Windows 3.1. Ciò viene comunque segnalato nella documentazione e/o nella descrizione del programma stesso.

In altri casi, più frequenti, possono invece essere richieste caratteristiche superiori, come ad esempio un processore Pentium, una scheda sonora, scheda grafica con accelerazione 3D (in particolare per i giochi), 64 MB di ram o la connessione ad Internet. Comunque, i requisiti richiesti da ogni programma sono sempre specificati nei file di documentazione che accompagnano tutto il materiale presentato.